Another question, UT2004 in W10

Post Reply
Rommie
Posts: 5
Joined: Fri Jul 17, 2015 7:35 am

Another question, UT2004 in W10

Post by Rommie »

Hi there, i have updated my Windows 7 pro, to Windows 10 pro 64bit, and my UT2004 has stopped working, all other games work fine, but UT2004 tell me:

Code: Select all

LockRect failed: D3DERR_DEVICELOST

History: UD3DRenderDevice::ReadPixels <- UD3DRenderDevice::Present <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- Level Untitled <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 10910191 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free
Anyone have any idea how to fix that?
I noticed after several times try to run game with this error, game starts in any "default" mode, in WINDOWED, BUT... when i switch back to FULLSCREEN it crash again with same error... All other games runs fine, INCLUDING Unreal engine games (Bioshock, 2, Mirror's Edge, Tera online, GoW, Blade and Soul, Devil May Cry 5, Smite, Mass Effect 1,2,3), and also third party engines (AioN, CS 1.6, Crysis 2, HL2, Guild Wars 2, ...) No problems anywhere, just in UT2004...
I tryed run game in compatibility mode, but nothing happened (still same error).. :/

User avatar
[SM]NEGATIVE-0
Posts: 16
Joined: Mon Nov 19, 2012 2:26 pm
Location: Charlotte NC
Contact:

Re: Another question, UT2004 in W10

Post by [SM]NEGATIVE-0 »

Have you found a solution to your problem with Windows 10 and UT2004?

User avatar
[SM]NEGATIVE-0
Posts: 16
Joined: Mon Nov 19, 2012 2:26 pm
Location: Charlotte NC
Contact:

Re: Another question, UT2004 in W10

Post by [SM]NEGATIVE-0 »

Run the 64-bit version of the game. Then edit your ut2004.ini.
Look for this header [Engine.Engine] and change these lines to,

[Engine.Engine]
;RenderDevice=D3D9Drv.D3D9RenderDevice
RenderDevice=OpenGLDrv.OpenGLRenderDevice

Post Reply