* Login   * Register    * Search
It is currently Tue Nov 19, 2019 1:02 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Sat Sep 15, 2018 7:38 pm 
Offline

Joined: Thu Sep 06, 2018 8:39 am
Posts: 10
Hi there, i had issues naming this thread and hope it is not too misleading.

I use two computers (both are WIN7) with UT 99 GOTY v4.51b in the same room for LAN gaming.
After finished setting up my Server,
i deleted the contents of the installed Client on the other computer,
copied the files from the Server to my Clients' installation folder (to make absolutely sure that they are 1:1 identical)
and changed the Clients' playername and playermodel.

Multiplayer worked fine.
Because i had this problem before, i made a backup copy of both working installations on their respective computers.

Then i added some playermodels, skins, maps and voicepacks to the Server
(by copying folders of unpacked UMOD files, which is much faster than installing 200 UMOD voicepacks as an example).

After that, i deleted all files and folders from the Client installation,
and copied over all files and folders from the modded Server Installation.
Again to be sure that Client and Server are identical.
Again i changed the Clients' playername and playermodel, so when i test other stuff in a multiplayer game,
I can tell the two players apart.

The weird thing is now, although BOTH, Client and Server have The Very Same Files,
the Client wants to download pretty much most maps (especially those that are not part of UT99GOTY)
from the Server.

I do not have the slightest clue why the Client does that, i checked a dozen of times but all folders of Client AND Server
are exactly identical, including time and date and size of all files
(apart of course from the changed INI files regarding playername and playermodel).

How do i fix that problem? (further, detailed information will be provided on request, of course)


Top
 Profile  
 
PostPosted: Sun Sep 16, 2018 1:27 am 
Offline
Super Moderator
Super Moderator

Joined: Mon Apr 12, 2010 5:05 am
Posts: 383
Probably you have not paste the files in the right place.

When you joint the server you download temporary files.
Make this temp files permanents using utcachecleaner on your ut player http://medor.no-ip.org/index.php?dir=ut ... eaner3.rar
And after that make a search for found where the file are.


For have a quick download for you and friends who want joint ; use a redirect on your ur server.
In the UnreaTournament.ini server

[IpDrv.HTTPDownload]
RedirectToURL=http://uz.overmindserver.net/
ProxyServerHost=
ProxyServerPort=3128
UseCompression=True

_________________
utfiles
utfiles medor
releases&updates
UnrealTournament-V3


Top
 Profile  
 
PostPosted: Sun Sep 16, 2018 2:57 am 
Offline

Joined: Thu Sep 06, 2018 8:39 am
Posts: 10
"Probably you have not paste the files in the right place."
I know my way around windows and UT regarding that :-)

"When you joint the server you download temporary files."
That is precisely the issue.
Again, Both computers have exactly the same files at the proper locations already.

So there is no need to download anything from anywhere and yet,
the client does download the maps (but no skins or playermodels) from the server.

My goal here is not to get the files to the client, neither by redirection or loading them from the server,
My goal is to have NO downloads to the client whatsoever, because, again, all files are already present.


Top
 Profile  
 
PostPosted: Sun Sep 16, 2018 3:09 am 
Offline
Super Moderator
Super Moderator

Joined: Mon Apr 12, 2010 5:05 am
Posts: 383
So you don't try the solution utcachecleaner as i say.
This is the only way to be sure .

If you don't download skins it's because you have not add it as serverpakages in the ut.ini.


Yes i know you don't want to download but i speak you about this if you want a friend joint.

_________________
utfiles
utfiles medor
releases&updates
UnrealTournament-V3


Top
 Profile  
 
PostPosted: Mon Sep 17, 2018 6:14 pm 
Offline
Site Admin
Site Admin

Joined: Fri Aug 21, 2009 4:59 am
Posts: 2589
What does the log say?

_________________
Like this site? Consider a donation to help with server costs.


Top
 Profile  
 
PostPosted: Wed Sep 19, 2018 6:00 am 
Offline

Joined: Thu Sep 06, 2018 8:39 am
Posts: 10
Sorry guys,
This whole endeavour already was annoying and tedious,
with the client computer only having a tv and not a monitor,
so the resolution was bad and always parts of the top screen
invisible, then i only have a 100 mbit network here.

Copying over stuff again and again is taking time and nerves.
(not to mention that waiting 4 minutes for the client to get a map
from the server is simply unacceptable)

But now... Earlier i emptied both server and client folders and
copied-in the stuff again so both are synchronized and _now_
the client cannot even connect to the server *groans*

I love fiddling about, making stuff work,
its why i started modding games so many decades ago,
but I have limits and mine regarding UT99 is reached.

Last time i played it with a friend in the LAN,
it worked after some fiddling, but back then i did not have
multicore processors, or tv-sets as monitors.

Thank you for your help :)

P.S.:
Installing Unreal Tournament 2004 ECE (GOG version) now...
I hate the playstationy GUI of it and miss xmaps and xbots and the cool anouncer already, but...
The playermodels and levels are so much more detailed
AND it works with my TV-monitor on the other computer very well :)


Top
 Profile  
 
PostPosted: Thu Sep 20, 2018 12:39 pm 
Offline

Joined: Thu Apr 17, 2008 11:07 pm
Posts: 701
Location: Minnesota USA
Good luck.

I am still kinda wondering about your problems with UT99 and playing on a lan.
It used to be SO easy to do :boink:

_________________
= Hook = Member# 5
SITE / FORUMS: http://hooksutplace.freeforums.net
UT99 PRO-Redeemer Server - CROSSBONES MISSILE MADNESS {CMM}
PRO-SNIPER-Redeemers | PRO-Redeemers | PRO-SEEKER-Redeemer | + FOOD FIGHT w/Fry Pan Arena
IP: 68.232.181.236:7777


Top
 Profile  
 
PostPosted: Thu Sep 20, 2018 3:13 pm 
Offline

Joined: Thu Sep 06, 2018 8:39 am
Posts: 10
Hook wrote:
Good luck.

I am still kinda wondering about your problems with UT99 and playing on a lan.
It used to be SO easy to do :boink:


*grins playfully angry*
Yeah, rub it in...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO